From: "Zebediah Figura (she/her)" Subject: Re: [PATCH vkd3d v2 1/7] tests: Separate the compile_shader function from the shader_test parser. Message-Id: <068e8292-5512-f67c-284b-f323aa1a35ca@codeweavers.com> Date: Mon, 17 Jan 2022 17:21:37 -0600 In-Reply-To: References: <20220114233308.49491-1-zfigura@codeweavers.com> On 1/17/22 08:29, Henri Verbeet wrote: > On Sat, 15 Jan 2022 at 00:33, Zebediah Figura wrote: >> >> In essence, the goal is to separate the d3d12 backend. Just separate the compiler first, though, to make the diff easier to read. >> >> NOTE TO SELF: Generate this diff with -C >> >> Signed-off-by: Zebediah Figura >> --- >> Makefile.am | 41 +- >> include/private/vkd3d_test.h | 19 +- >> tests/shader_runner.c | 862 +++++++++++++++++++++++++++++++++++ >> tests/shader_runner.h | 29 ++ >> tests/shader_runner_d3d12.c | 847 +--------------------------------- >> 5 files changed, 947 insertions(+), 851 deletions(-) >> create mode 100644 tests/shader_runner.c >> create mode 100644 tests/shader_runner.h >> > This patch introduces warnings for "make crosstest": > > /tests/shader_runner.c:463:38: warning: format ‘%x’ expects > argument of type ‘unsigned int’, but argument 4 has type ‘HRESULT’ > {aka ‘long int’} [-Wformat=] > ok(hr == E_FAIL, "Got unexpected hr %#x.\n", hr); These warnings are basically an existing problem with the MinGW build of vkd3d, which is probably why I disregarded them. I guess the best solution here is to define HRESULT as int always.